Forums
Discussions and forums
Valarsoft forum section, you can register to write in the forums or you can only read forum posts.
You can post in english (main language) or italian (if you prefer).

All the forums Webmatic Webmatic version 3.0.x
only in discussions
Webmatic version 3.0.x
Discussions about Webmatic version 3.0.x
Creato il July 13 2009 (18:54:57), moderator: arraffaele (group: Default)
You can: read posts.

Author Message

paolo
June 28 2011 (17:33:00)

webmatic 308

Salve, sono nuovo di questo forum, prima di tutto voglio fare i complimenti a chi ha ideao e progettato webmatic.
Sono così entusiasta di webmatic che ho subito voluto provarlo effettuando una istallazione in locale con phpmyadmin.
l'istallazione è andata buon fine ma subito dopo collegandomi alla home page o nell'area admin mi compaiono una serie di messaggi nella parte superiore della home tipo:

Strict Standards: Non-static method webmatic3::getVariable() should not be called statically in C:\Programmi\EasyPHP-5.3.6.0\www\core\classes\webmatic3.php on line 269

ho provato a controllare il codice in webmatic3.php alla linea 269 ma non essendo un esperto in php non saprei cosa modificare.
Cosa mi consigliate?

arraffaele
June 28 2011 (17:56:57)

Ciao,
devi semplicemente disabilitare la modalità strict dell'error_reporting di php.

Per farlo con easyphp clicca con il mouse destro sull'icona di easyphp (sulla barra in basso a destra) vai su Configurazione->PHP, ti apparira' il file php.ini da modificare,
cerca all'interno del file la voce "error_reporting" non commentata (l'unica senza ";" davanti) e cancella l'opzione E_STRICT, dovresti ottenere una riga simile a questa

error_reporting = E_ALL

Poi salva il tutto e prova a ricaricare la pagina di webmatic che ti dava i messaggi... ciao e buon divertimento!

paolo
June 28 2011 (18:21:56)

Grazie arraffaele, veramente mille grazie problema risolto.


Total visitors 249939 (366 today) (Page generated in 0.17668 seconds, 57 queries)
Powered by: Webmatic 3.1.2 beta